Uniden's New SDS100 is now shipping - Here are my thoughts
w2lie, Fri Jun 08 2018, 04:59am


News item posted
thumb_screen_shot_2018-06-06_at_9.29.59_pm.pngUniden has a new flagship model out, and it is the SDS100

This new radio is built around the very popular SDR technology.   In theory, this radio should do extremely well in P25 simulcast environments.  Fortunately for us here on Long Island, we don't have much of a problem when it comes to P25 simulcast.

I've setup a page where I will be reviewing the SDS100.  You can visit www.sds100review.com for more information on what I think of the radio.   While you are there, please sign up for my e-mail list so you can stay up to date while I play around with the radio.

There is also my unboxing video on Facebook at and also on my new YouTube channel.

I will be hosting a live Facebook Q&A this coming Saturday 6/9/18 and I'm sure there will be plenty of questions on the SDS100.  Feel free to check it out on the Scanner School Facebook page
 
 
If you are in the market for a Uniden SDS100, we have an affiliate program with ScannerMaster.   If you use our link to purchase an SDS100 or anything else at Scanner Master, w2lie.net will earn a small commission on anything you purchase.   This is a great way to help support w2lie.net without it costing you any extra.



 


Re: Uniden's New SDS100 is now shipping - Here are my thoughts
PFD Mike, Fri Jun 08 2018, 06:50am

I'm having problems with the page.

Message I'm getting

"The server at (www.sds100review.com) is taking too long to respond."

Re: Uniden's New SDS100 is now shipping - Here are my thoughts
ipfd320, Fri Jun 08 2018, 07:12am

Im Getting the Same Message here also

Re: Uniden's New SDS100 is now shipping - Here are my thoughts
w2lie, Fri Jun 08 2018, 01:34pm

Thanks for the heads up. I've 'fixed' the link. The issue has to do with the way GoDaddy forwards https requests I guess.
SDS100Review is using SSL (so it is Google Friendly) and I used that for my link in the main post. It seems that passing through GoDaddy only works when I used http and not https.

I'll get that fixed on the routing side, but the link is patched to work for now.

Let me know what you all think.